
LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = (𝑥 + 𝑦)(𝑥 + 𝑧)(𝑦 + 𝑧), 

b) 𝑊2 = 𝑥 + 𝑥𝑧. 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 

 

Literatura 

▪ I. Pająk, G. Pająk – Cyfrowe układy automatyki przemysłowej, Oficyna Wydawnicza Uniwersytetu 

Zielonogórskiego, Zielona Góra 2023 

▪ Siemens – Podręcznik pierwsze kroki z SIMATIC S7-1200, link do pliku pdf na stronie przedmiotu 
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LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = 𝑥𝑦 + 𝑦𝑧 + 𝑥𝑧, 

b) 𝑊2 = 𝑥(𝑥 + 𝑧). 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku i LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 

 

Literatura 

▪ I. Pająk, G. Pająk – Cyfrowe układy automatyki przemysłowej, Oficyna Wydawnicza Uniwersytetu 

Zielonogórskiego, Zielona Góra 2023 

▪ Siemens – Podręcznik pierwsze kroki z SIMATIC S7-1200, link do pliku pdf na stronie przedmiotu 
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LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = (𝑥 + 𝑦)(𝑥 + 𝑧)(𝑦 + 𝑧), 

b) 𝑊2 = 𝑦 + 𝑥𝑦. 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku i LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 

 

Literatura 

▪ I. Pająk, G. Pająk – Cyfrowe układy automatyki przemysłowej, Oficyna Wydawnicza Uniwersytetu 

Zielonogórskiego, Zielona Góra 2023 

▪ Siemens – Podręcznik pierwsze kroki z SIMATIC S7-1200, link do pliku pdf na stronie przedmiotu 
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LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = 𝑥𝑦 + 𝑥𝑧 + 𝑦𝑧, 

b) 𝑊2 = 𝑦(𝑥 + 𝑦). 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku i LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 

 

Literatura 

▪ I. Pająk, G. Pająk – Cyfrowe układy automatyki przemysłowej, Oficyna Wydawnicza Uniwersytetu 

Zielonogórskiego, Zielona Góra 2023 

▪ Siemens – Podręcznik pierwsze kroki z SIMATIC S7-1200, link do pliku pdf na stronie przedmiotu 
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LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = (𝑥 + 𝑧)(𝑥 + 𝑦)(𝑦 + 𝑧), 

b) 𝑊2 = 𝑧 + 𝑦𝑧. 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku i LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 
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LABORATORIUM 02  

  Elementy automatyki 

PROGRAMOWANIE STEROWNIKÓW PLC Z WYKORZYSTANIEM JĘZYKA LD 

Cel zajęć 

Zapoznanie z podstawami programowania układów logicznych z wykorzystaniem języka LD. 

Materiały do przygotowania 

• Cyfrowe układy automatyki przemysłowej:  

▪ Rozdział 2: Funkcje logiczne (punkty 2.1, 2.2 i 2.3) 

▪ Rozdział 8: Sterowniki PLC – język LD (punkt 8.1) 

Zadania cz.1. Do wykonania przed zajęciami 

1. Przeprowadź analizę poniższych funkcji logicznych i sporządź ich tablice prawdy (uwaga: tablica 

funkcji n-argumentowej ma 2𝑛 wierszy w tym przypadku 23 = 8 – patrz przykłady w podręczniku): 

a) 𝑊1 = 𝑥𝑦 + 𝑥𝑧 + 𝑦𝑧, 

b) 𝑊2 = 𝑧(𝑦 + 𝑧). 

2. Zastanów się jak zapisać funkcje 𝑊1 i 𝑊2 w języku i LD (tylko do przemyślenia bez zapisu). 

Uwaga: rozwiązania zadania 1 zapisz w pliku o nazwie: nazwisko_lab02 i prześlij jako rozliczenie projektu 

w Classroom na dzień przed zajęciami (do północy dnia poprzedzającego zajęcia). 

Zadania cz.2. Do wykonania na zajęciach 

1. Utwórz projekt o nazwie lab02 i korzystając z języka LD napisz program dla urządzenia sterującego o 

trzech wejściach (x, y, z) i dwóch wyjściach (W1, W2), którego działanie jest opisane funkcjami 

logicznymi podanymi w zad. 1 w części 1. Przyjmij że: 

• sygnały wejściowe x, y, z są podłączone do wejścia o adresie 0, kolejno do bitów nr 4, 5, i 6, 

• sygnały wyjściowe W1 i W2 są podłączone do wyjścia adresie 0, kolejno do bitów nr 0 i 1. 

Załaduj program do sterownika i przetestuj jego działanie. Sprawdź czy układ działa zgodnie z 

przygotowanymi w części 1 tabelami prawdy. 

2. Uzupełnij informacje o autorach (opcja Edit → Properties → Information → Author), kod programu, 

oraz zdefiniowaną tablicę tagów (zmiennych) zapisz w plikach pdf o nazwach nazwisko_lab02_prg, 

nazwisko_lab02_tagi (opcja Project → Print, lub skrót Ctrl+P w oknie programu). 

Uwaga: zapisane pliki pdf prześlij jako rozliczenie projektu w Classroom. 
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